Bienvenue sur IndexError.

Ici vous pouvez poser des questions sur Python et le Framework Django.

Consultez la FAQ pour améliorer vos chances d'avoir des réponses à vos questions.

Qu'est-ce qui cause cette erreur sur la compilation opencv 3.0 ?

+2 votes

La compilation d'opencv 3.0 sous linux affiche l'erreur suivante:

Distrib: CentOS 6.5

cmake -D CMAKE_BUILD_TYPE=RELEASE -D BUILD_NEW_PYTHON_SUPPORT=ON -D PYTHON_EXECUTABLE=/usr/local/bin/python -D PYTHON_LIBRARY=/usr/local/lib/ -D PYTHON_INCLUDE_DIR=/usr/local/include/python2.7 -D CMAKE_INSTALL_PREFIX=/usr/local ..

make

....
....
[ 23%] Built target pch_Generate_opencv_highgui
make[2]: *** [modules/highgui/CMakeFiles/opencv_highgui.dir/src/grfmt_tiff.cpp.o] Erreur 1
demandé 2-Jan-2015 par max (894 points)

Ça manque d'information :)

Ça donne quoi avec "make VERBOSE=1" ?

Quelle version de opencv 3.0 (en tout cas chez moi la 3.0.0 beta compile)

PS: l'interface a un bug car sous firefox on peut pas scroller le code allant trop à droite

ok on va regarder ça, merci!

1 Réponse

+2 votes
 
Meilleure réponse

Il fallait installer les paquets devel de tiff.

yum install libtiff-devel
répondu 2-Jan-2015 par max (894 points)
...